inserire in sequenza


Domanda: In una colonna voglio far comparire nella cella 5 i dati inseriti nell'ultima cella libera delle 4 precedenti (esempio: se nella cella uno scrivo a, poi nella due scrivo b, e nella tre scrivo c; man mano che inserisco le varie lettere voglio che automaticamente mi si aggiorni la cella 5)

 

Risposta:
la formula sequente permette di fare quanto richiesto:

=SE(A5<>"";A5;SE(A4<>"";A4;SE(A3<>"";A3;SE(A2<>"";A2;SE(A1<>"";A1;"")))))

copiatela in una cella qualsiasi (ad esempio B10) e provate a inserire i valori in A1, A2, A3, A4, A5.

la formula una serie di SE innestati uno nell'altro:
se c'e' qualcosa in A5, lo scrivi, altrimenti vai a vedere in A4, se c'e' qualcosa lo scrivi, altrimenti vai in A3 etc etc etc
per modificare la cella per inserir e pi celle su cui "eseguire la sequenza" semplice, basta togliere o mettere dei SE uno dentro l'altro.

 

AGGIORNAMENTO: Massimiliano Salvatori mi ha gentilmente inviato un file che mostra come realizzare l'inserimento in sequenza senza la complicata serie di SE proposta ma utilizzando invece in modo molto originale la funzione CERCA.VERT. Potete scaricare l'esempio di Massimiliano al seguente indirizzo:

 

http://www.terzaghi.it/excel/faq/risposte/xls/inserireinsequenza.zip