CERCA.VERT trova da solo il foglio su cui cercare!


Domanda: In una formula tipo =CERCA.VERT(C6;casa!A2:B18;2;0), dove "casa" Ŕ il
nome del foglio nel quale cercare i dati, Ŕ possibile sostiture i riferimenti del foglio con una cella nella quale compare il nome del foglio,
grazie alla formula: "=STRINGA.ESTRAI(CELLA("FILENAME";G76);TROVA("]";CELLA("FILENAME";G7
6))+1;255)" giÓ presente sul tuo sito.

Se fosse possibile potrei copiare le formule da un foglio all'altro senza intervenire manualmente nella modifica della formula cerca verticale.

 

Risposta:
Devi utilizzare la funzione "INDIRETTO" in questo modo:

=CERCA.VERT(A2;INDIRETTO(B2&"!A2:B18");2;0)

dove in B2 ci sarÓ il nome del file da cui prendere il dato.

scarica dal link sotto un file di esempio:
www.terzaghi.it/excel/faq/risposte/xls/indiretto.zip