verificare se un certo dato e' presente o meno in una certa lista


Domanda: Ho un elenco di codici cliente. Vorrei verificare quali di questi sono presenti o meno nell'anagrafica dei codici cliente. Come si puo' fare velocemente?

 

Risposta:
Utilizza la funzione CERCA.VERT in questo modo.
Diciamo che il database dei codici cliente si trova nel foglio DB nella colonna A e l'elenco dei codici si trova nella colonna A del foglio di lavoro corrente a partire dalla cella A2.
Nella cella B2 del foglio di lavoro corrente (a fianco della cella contenente il primo codice cliente da verificare) inserite la seguente formula:


=SE(VAL.NON.DISP(CERCA.VERT(A2;DB!A:A;1;0));"NON PRESENTE";"PRESENTE")

 

la formula attraverso un CERCA.VERT verifica nella lista in DB l'esistenza del codice. Se il codice esiste allora CERCA.VERT lo restituisce e dunque non restituisce un errore. In questo caso VAL.NON.DISP risulta FALSO e viene allora scritto PRESENTE. el caso in cui il codice non sia presente in DB allora il CERCA.VERT restituisce un errore, VAL.NON.DISP rileva l'errore e dunque viene stampato NON PRESENTE.
A questo punto con semplici filtri, pivot o la funzione CONTA.SE e' possibile contare quanti e quali codici cliente non sono presenti nel DB.

 

AGGIORNAMENTO: Massimiliano Salvatori mi segnala gentilmente una seconda formula per ottenere lo stesso scopo:

=SE(CONTA.SE(A2:B100;E3)=0;0;CERCA.VERT(E3;A2:B100;2;FALSO))

 

Attraverso il CONTA.SE si ottiene lo stesso identico risultato. le celle che conterranno 0 saranno quelle per le quali il dato non stato trovato nel DB.