cercare una parola in un testo con Excel


Domanda: volevo sapere se e' possibile effettuare una ricerca di una porzione di testo all'interno di celle contenenti un testo pi esteso. Mi spiego: in ogni cella della colonna A pu essere contenuto un testo variabile.
Nella corrispondente cella adiacente della colonna B vorrei apprisse "vero" o "falso" a seconda che una porzione di testo dato sia presente o meno nella cella della colonna adiacente.
esempio:
nella cella A1 puo' essere scritto una combinazione tra i tre nomi pizza, birra, dolce (pizzabirra, birradolce, dolcebirrapizza ecc) nella cella B1 vorrei apparisse "vero" se in A1 c il testo pizza, "falso" se no.

 

Risposta:
pi facile di quanto si possa immaginare, la formula da usare e':

=TROVA(COSA; DOVE)

ad esempio, in A1 c' il testo da cercare e in A2 la stringa che (forse) contiene il testo
la forumla =TROVA(A1;A2)

se "TROVA" trova la stringa A1 in A2 allora restituisce un numero che rappresenta la posizione del primo carattere di A1 in A2. Quindi per sapere se una certa stringa (parola) e' contenuta in un'altra basta verificare se TROVA resituisce un numero o un errore.
la formula da usare allora:

=SE(VAL.ERRORE(TROVA(A1;A2));"no";"si")

se la parola in A1 contenuta nella frase in A2 avremo un bel "si" altrimenti "no"