numeri in formato testo


Domanda: Ogni volta in cui copio ed incollo dei dati su un foglio di excel i numeri sono in formato testo. Sulle celle appare un triangolo verde in alto a sinistra e l'unico modo per elaborare i numeri è quello di cliccare sopra il triangolo e scegliere "Convert to number". Non so come togliere questo problema perchè ogni volta devo manualmente andare a correggere le celle. Grazie, Anna

 

Risposta:
in una colonna adiacente inserisci la formula

=VALORE(A1)

e trascina la cella verso il basso in modo da estendere la formula a tutta la colonna.

nel caso in cui alcuni campi della colonna contengano non dei valori ma dei testi questi non devono essere convertiti. Quando la funzione VALORE cerca di convertire un testo e non un numero si ottiene infatti "#VALORE!". Bisogna allora bisogna inserire la formula:

=SE(VAL.ERRORE(VALORE(A1));A1;VALORE(A1))

che in sostanza prova a convertire il dato in A1, se non ci riesce lo restituisce senza conversione altrimenti lo restituisce convertito.

a questo punto avete una colonna con i dati convertiti. Andate sulla prima colonna, selezionatela, premete CTRL+1 e verificate che il formate delle celle NON SIA "Testo" ma "Generale".
Ora potete tornare sulla colonna dei dati convertiti e premere CTRL+C, tornate sulla prima colonna (quella contenente i testi) eseguire:

modifica -> incolla speciale -> valori

in questo modo avrete la colonna iniziale con i valori numerici che, invece di essere considerati come testi, saranno interpretati da Excel come valori sui quali poter finalmente applicare le formule matematiche o di ricerca tipo "CERCA.VERT"