Estrazione di una formula da una cella Excel


Gian mi chiede se sia possibile determinare se una cella contiene una formula e riportare il risultato su una cella. 

Di seguito una piccola funzione da inserire nel file Excel che permette di scrivere direttamente la formula all'interno della cella Excel:

 

____________________________________________

 

Function EstraiFormula(c As Range) As String
If Left(c.Formula, 1) = "=" Then
EstraiFormula = c.Formula
Else
EstraiFormula = ""
End If

End Function

 

____________________________________________

 

Per poter utilizzare la funzione é necessario inserire nel foglio Excel:

 

=EstraiFormula(A1)

 

Nella cella dove si è inserito tale formula non apparirà nulla se in A1 è contenuto un valore e invece la formula contenuta nella cella A1 in caso contrario. Ad esempio comparirà la formula =A5*B22

Se poi si desidera semplicemente sapere se si tratta di una formula oppure no basta scrivere:

 

=SE(EstraiFormula(A1)<>"";"Si";"No")


Licenza Creative Commons

Questa opera è pubblicata sotto una Licenza Creative Commons.
Scarica il File di Esempio


iscriviti cancellati



Commenti a questa pagina:   Inviate una mail